PDA

View Full Version : Welcome Screen and fast user switching very broken



fburleigh@gmail.com
19-07-2005, 09:44 AM
A colleague's home XP Pro sp2 machine has some nasty troubles. Here's
what's wrong--and in my description I'll correlate with today's
googling results for this group of problems:

1. Instead of the Welcome Screen with a list of users, we get the
regular login prompt over a black screen. But the login type is set to
use the Welcome Screen (winlogin\logintype is 1 in the registry). I
don't see other ginas being used, and the registry userinit value is
c:\...\userinit.exe. The Fast User switch service is automatic and
running, as is terminal services (both had been set to manul; at least
now the machine can start straight to a user). I've seen Doug Knox'
"fix welcome screen" repoting tool; it claims all is well.

2. logonui.exe seems to crash a lot. At one point while I was trying
to shut down the machine I saw maybe 10 repeated logonui.exe
experienced problems, please report to Microsoft prompts. Each time I
let the faulting app mechanism report the problems to MS. Finally the
machine shut down.

3. Fast User switching is very broken. Logoff, Switch Users clears the
desktop of all but the wallpaper, then more or less hangs. The "wait"
mouse cursor is on screen and can be moved, but even after several
minutes of waiting, we never go to some other prompt or to shutdown.
My guess is FUS' failing is related to the problems in the Welcome
Screen.

Anything else I can do? Let's say I have to use a recovery method:
would that do anything not already done above? Would I have to reapply
service packs? *Can* one even reapply service packs these days? ;-)

Thanks everyone.

Mark L. Ferguson
19-07-2005, 11:40 PM
To repair all system files, go to Start/Run, and type: SFC /SCANNOW

--
Mark L. Ferguson
FAQ for Windows Antispy http://www.geocities.com/marfer_mvp/FAQ_MSantispy.htm
<fburleigh@gmail.com> wrote in message news:1121729944.335702.281360@g14g2000cwa.googlegr oups.com...
>A colleague's home XP Pro sp2 machine has some nasty troubles. Here's
> what's wrong--and in my description I'll correlate with today's
> googling results for this group of problems:
>
> 1. Instead of the Welcome Screen with a list of users, we get the
> regular login prompt over a black screen. But the login type is set to
> use the Welcome Screen (winlogin\logintype is 1 in the registry). I
> don't see other ginas being used, and the registry userinit value is
> c:\...\userinit.exe. The Fast User switch service is automatic and
> running, as is terminal services (both had been set to manul; at least
> now the machine can start straight to a user). I've seen Doug Knox'
> "fix welcome screen" repoting tool; it claims all is well.
>
> 2. logonui.exe seems to crash a lot. At one point while I was trying
> to shut down the machine I saw maybe 10 repeated logonui.exe
> experienced problems, please report to Microsoft prompts. Each time I
> let the faulting app mechanism report the problems to MS. Finally the
> machine shut down.
>
> 3. Fast User switching is very broken. Logoff, Switch Users clears the
> desktop of all but the wallpaper, then more or less hangs. The "wait"
> mouse cursor is on screen and can be moved, but even after several
> minutes of waiting, we never go to some other prompt or to shutdown.
> My guess is FUS' failing is related to the problems in the Welcome
> Screen.
>
> Anything else I can do? Let's say I have to use a recovery method:
> would that do anything not already done above? Would I have to reapply
> service packs? *Can* one even reapply service packs these days? ;-)
>
> Thanks everyone.
>

Hosted by: Eyo Technologies Pty Ltd. Sponsored by: Actiontec Pty Ltd