PDA

View Full Version : ??? Cannot Compress Drive ???



Ext User(Alan Foxmore)
01-06-2007, 09:23 PM
Hi everyone,

I'm an administrator on my XP Pro SP2 machine.

I have a hard drive attached to my machine via a USB 2.0 drive enclosure
(I'm not sure if this fact is even relevant). I can use the drive with no
problems. When I right click on the drive letter and view properties,
"General" tab, I see I do *not* have the option of compressing this drive
for some reason.

Oddly, I have a second hard drive attached to the same machine via another
drive enclosure and this drive *does* have the option to compress.

Both drives are NTFS.

Can someone offer some insight as to why the one drive cannot be compressed?

Thanks very much.

Alan

Ext User(David H. Lipman)
01-06-2007, 09:43 PM
From: "Alan Foxmore" <afoxmore@yahoo.com>

| Hi everyone,
|
| I'm an administrator on my XP Pro SP2 machine.
|
| I have a hard drive attached to my machine via a USB 2.0 drive enclosure
| (I'm not sure if this fact is even relevant). I can use the drive with no
| problems. When I right click on the drive letter and view properties,
| "General" tab, I see I do *not* have the option of compressing this drive
| for some reason.
|
| Oddly, I have a second hard drive attached to the same machine via another
| drive enclosure and this drive *does* have the option to compress.
|
| Both drives are NTFS.
|
| Can someone offer some insight as to why the one drive cannot be compressed?
|
| Thanks very much.
|
| Alan
|

NTFS or FAT32 ?

--
Dave
http://www.claymania.com/removal-trojan-adware.html
http://www.ik-cs.com/got-a-virus.htm

Ext User(JS)
01-06-2007, 09:43 PM
Have you used Disk Manager to Enable drive compression (check the drive
properties in Disk Manager)?

JS

"Alan Foxmore" <afoxmore@yahoo.com> wrote in message
news:Ok6XWv9oHHA.588@TK2MSFTNGP06.phx.gbl...
> Hi everyone,
>
> I'm an administrator on my XP Pro SP2 machine.
>
> I have a hard drive attached to my machine via a USB 2.0 drive enclosure
> (I'm not sure if this fact is even relevant). I can use the drive with no
> problems. When I right click on the drive letter and view properties,
> "General" tab, I see I do *not* have the option of compressing this drive
> for some reason.
>
> Oddly, I have a second hard drive attached to the same machine via another
> drive enclosure and this drive *does* have the option to compress.
>
> Both drives are NTFS.
>
> Can someone offer some insight as to why the one drive cannot be
> compressed?
>
> Thanks very much.
>
> Alan
>

Ext User(Alan Foxmore)
01-06-2007, 09:53 PM
"David H. Lipman" <DLipman~nospam~@Verizon.Net> wrote in message
news:OP2r0P%23oHHA.3948@TK2MSFTNGP05.phx.gbl...
> From: "Alan Foxmore" <afoxmore@yahoo.com>
>
> | Hi everyone,
> |
> | I'm an administrator on my XP Pro SP2 machine.
> |
> | I have a hard drive attached to my machine via a USB 2.0 drive enclosure
> | (I'm not sure if this fact is even relevant). I can use the drive with
> no
> | problems. When I right click on the drive letter and view properties,
> | "General" tab, I see I do *not* have the option of compressing this
> drive
> | for some reason.
> |
> | Oddly, I have a second hard drive attached to the same machine via
> another
> | drive enclosure and this drive *does* have the option to compress.
> |
> | Both drives are NTFS.
> |
> | Can someone offer some insight as to why the one drive cannot be
> compressed?
> |
> | Thanks very much.
> |
> | Alan
> |
>
> NTFS or FAT32 ?

As I indicated in my original post, both drives are NTFS.

Ext User(JS)
01-06-2007, 10:03 PM
Click Start/Administrative Tools/Computer Management/Storage/Disk
Management.
Do you see the drive listed, if so click on the drive letter and then right
click and select the 'Properties' Option.
Down near the bottom of the drive properties window you should see a check
box labeled:
'Compress drive to save disk space',
check the box and then click 'Apply',
Now you should see options to: compress only files in the root or root and
all subfolders.

JS

"Alan Foxmore" <afoxmore@yahoo.com> wrote in message
news:O8A7fd%23oHHA.4960@TK2MSFTNGP02.phx.gbl...
>
> "JS" <@> wrote in message news:upvnzW%23oHHA.1244@TK2MSFTNGP04.phx.gbl...
>> Have you used Disk Manager to Enable drive compression (check the drive
>> properties in Disk Manager)?
>
> What's Disk Manager? This is not a USB flash device. It's an IDE drive
> that's attached via a USB drive enclosure.
>
> I have two of these things. One of them is compressed while the other is
> not. On the one that is not compressed I do not have the checkbox option
> for compressing it. Here is a screen shot (I hope it comes through).
> Notice I do not have the checkbox that would normally appear allowing the
> drive to be compressed.
>
>
>
>>
>> "Alan Foxmore" <afoxmore@yahoo.com> wrote in message
>> news:Ok6XWv9oHHA.588@TK2MSFTNGP06.phx.gbl...
>>> Hi everyone,
>>>
>>> I'm an administrator on my XP Pro SP2 machine.
>>>
>>> I have a hard drive attached to my machine via a USB 2.0 drive enclosure
>>> (I'm not sure if this fact is even relevant). I can use the drive with
>>> no
>>> problems. When I right click on the drive letter and view properties,
>>> "General" tab, I see I do *not* have the option of compressing this
>>> drive
>>> for some reason.
>>>
>>> Oddly, I have a second hard drive attached to the same machine via
>>> another
>>> drive enclosure and this drive *does* have the option to compress.
>>>
>>> Both drives are NTFS.
>>>
>>> Can someone offer some insight as to why the one drive cannot be
>>> compressed?
>>>
>>> Thanks very much.
>>>
>>> Alan
>>>
>>
>>
>
>
>

Ext User(JS)
01-06-2007, 10:03 PM
Click Start/Administrative Tools/Computer Management/Storage/Disk
Management.
Do you see the drive listed, if so click on the drive letter and then right
click and select the 'Properties' Option.
Down near the bottom of the drive properties window you should see a check
box labeled:
'Compress drive to save disk space',
check the box and then click 'Apply',
Now you should see options to: compress only files in the root or root and
all subfolders.

JS

"Alan Foxmore" <afoxmore@yahoo.com> wrote in message
news:O8A7fd%23oHHA.4960@TK2MSFTNGP02.phx.gbl...
>
> "JS" <@> wrote in message news:upvnzW%23oHHA.1244@TK2MSFTNGP04.phx.gbl...
>> Have you used Disk Manager to Enable drive compression (check the drive
>> properties in Disk Manager)?
>
> What's Disk Manager? This is not a USB flash device. It's an IDE drive
> that's attached via a USB drive enclosure.
>
> I have two of these things. One of them is compressed while the other is
> not. On the one that is not compressed I do not have the checkbox option
> for compressing it. Here is a screen shot (I hope it comes through).
> Notice I do not have the checkbox that would normally appear allowing the
> drive to be compressed.
>
>
>
>>
>> "Alan Foxmore" <afoxmore@yahoo.com> wrote in message
>> news:Ok6XWv9oHHA.588@TK2MSFTNGP06.phx.gbl...
>>> Hi everyone,
>>>
>>> I'm an administrator on my XP Pro SP2 machine.
>>>
>>> I have a hard drive attached to my machine via a USB 2.0 drive enclosure
>>> (I'm not sure if this fact is even relevant). I can use the drive with
>>> no
>>> problems. When I right click on the drive letter and view properties,
>>> "General" tab, I see I do *not* have the option of compressing this
>>> drive
>>> for some reason.
>>>
>>> Oddly, I have a second hard drive attached to the same machine via
>>> another
>>> drive enclosure and this drive *does* have the option to compress.
>>>
>>> Both drives are NTFS.
>>>
>>> Can someone offer some insight as to why the one drive cannot be
>>> compressed?
>>>
>>> Thanks very much.
>>>
>>> Alan
>>>
>>
>>
>
>
>

Ext User(Alan Foxmore)
01-06-2007, 10:43 PM
"JS" <@> wrote in message news:u9i6x6%23oHHA.3368@TK2MSFTNGP02.phx.gbl...
> Click Start/Administrative Tools/Computer Management/Storage/Disk
> Management.
> Do you see the drive listed, if so click on the drive letter and then
> right
> click and select the 'Properties' Option.
> Down near the bottom of the drive properties window you should see a check
> box labeled:
> 'Compress drive to save disk space',
> check the box and then click 'Apply',
> Now you should see options to: compress only files in the root or root and
> all subfolders.
>

The dialog window you are referring to is the same one you see if you
right-click the drive in Explorer. There's no need to into "Disk Manager".

At any rate, that dialog window does not have the option to compress the
drive. I posted a screen shot of the dialog window in my previous post. You
will see the option is not present.






>
> "Alan Foxmore" <afoxmore@yahoo.com> wrote in message
> news:O8A7fd%23oHHA.4960@TK2MSFTNGP02.phx.gbl...
>>
>> "JS" <@> wrote in message news:upvnzW%23oHHA.1244@TK2MSFTNGP04.phx.gbl...
>>> Have you used Disk Manager to Enable drive compression (check the drive
>>> properties in Disk Manager)?
>>
>> What's Disk Manager? This is not a USB flash device. It's an IDE drive
>> that's attached via a USB drive enclosure.
>>
>> I have two of these things. One of them is compressed while the other is
>> not. On the one that is not compressed I do not have the checkbox option
>> for compressing it. Here is a screen shot (I hope it comes through).
>> Notice I do not have the checkbox that would normally appear allowing the
>> drive to be compressed.
>>
>>
>>
>>>
>>> "Alan Foxmore" <afoxmore@yahoo.com> wrote in message
>>> news:Ok6XWv9oHHA.588@TK2MSFTNGP06.phx.gbl...
>>>> Hi everyone,
>>>>
>>>> I'm an administrator on my XP Pro SP2 machine.
>>>>
>>>> I have a hard drive attached to my machine via a USB 2.0 drive
>>>> enclosure
>>>> (I'm not sure if this fact is even relevant). I can use the drive with
>>>> no
>>>> problems. When I right click on the drive letter and view properties,
>>>> "General" tab, I see I do *not* have the option of compressing this
>>>> drive
>>>> for some reason.
>>>>
>>>> Oddly, I have a second hard drive attached to the same machine via
>>>> another
>>>> drive enclosure and this drive *does* have the option to compress.
>>>>
>>>> Both drives are NTFS.
>>>>
>>>> Can someone offer some insight as to why the one drive cannot be
>>>> compressed?
>>>>
>>>> Thanks very much.
>>>>
>>>> Alan
>>>>
>>>
>>>
>>
>>
>>
>
>
>

Ext User(JS)
01-06-2007, 11:13 PM
Only other thing I know of is that compression option may require a cluster
size of 4k (default) when formatting.

Karen's Disk Slack Checker v2.5.2
http://www.karenware.com/powertools/ptslack.asp

JS

"Alan Foxmore" <afoxmore@yahoo.com> wrote in message
news:OvkfIO$oHHA.5052@TK2MSFTNGP04.phx.gbl...
>
> "JS" <@> wrote in message news:u9i6x6%23oHHA.3368@TK2MSFTNGP02.phx.gbl...
>> Click Start/Administrative Tools/Computer Management/Storage/Disk
>> Management.
>> Do you see the drive listed, if so click on the drive letter and then
>> right
>> click and select the 'Properties' Option.
>> Down near the bottom of the drive properties window you should see a
>> check
>> box labeled:
>> 'Compress drive to save disk space',
>> check the box and then click 'Apply',
>> Now you should see options to: compress only files in the root or root
>> and
>> all subfolders.
>>
>
> The dialog window you are referring to is the same one you see if you
> right-click the drive in Explorer. There's no need to into "Disk Manager".
>
> At any rate, that dialog window does not have the option to compress the
> drive. I posted a screen shot of the dialog window in my previous post.
> You will see the option is not present.
>
>
>
>
>
>
>>
>> "Alan Foxmore" <afoxmore@yahoo.com> wrote in message
>> news:O8A7fd%23oHHA.4960@TK2MSFTNGP02.phx.gbl...
>>>
>>> "JS" <@> wrote in message
>>> news:upvnzW%23oHHA.1244@TK2MSFTNGP04.phx.gbl...
>>>> Have you used Disk Manager to Enable drive compression (check the drive
>>>> properties in Disk Manager)?
>>>
>>> What's Disk Manager? This is not a USB flash device. It's an IDE drive
>>> that's attached via a USB drive enclosure.
>>>
>>> I have two of these things. One of them is compressed while the other is
>>> not. On the one that is not compressed I do not have the checkbox option
>>> for compressing it. Here is a screen shot (I hope it comes through).
>>> Notice I do not have the checkbox that would normally appear allowing
>>> the
>>> drive to be compressed.
>>>
>>>
>>>
>>>>
>>>> "Alan Foxmore" <afoxmore@yahoo.com> wrote in message
>>>> news:Ok6XWv9oHHA.588@TK2MSFTNGP06.phx.gbl...
>>>>> Hi everyone,
>>>>>
>>>>> I'm an administrator on my XP Pro SP2 machine.
>>>>>
>>>>> I have a hard drive attached to my machine via a USB 2.0 drive
>>>>> enclosure
>>>>> (I'm not sure if this fact is even relevant). I can use the drive with
>>>>> no
>>>>> problems. When I right click on the drive letter and view properties,
>>>>> "General" tab, I see I do *not* have the option of compressing this
>>>>> drive
>>>>> for some reason.
>>>>>
>>>>> Oddly, I have a second hard drive attached to the same machine via
>>>>> another
>>>>> drive enclosure and this drive *does* have the option to compress.
>>>>>
>>>>> Both drives are NTFS.
>>>>>
>>>>> Can someone offer some insight as to why the one drive cannot be
>>>>> compressed?
>>>>>
>>>>> Thanks very much.
>>>>>
>>>>> Alan
>>>>>
>>>>
>>>>
>>>
>>>
>>>
>>
>>
>>
>
>

Ext User(Carl Kaufmann)
02-06-2007, 04:33 AM
Alan Foxmore wrote:
> Hi everyone,
>
> I'm an administrator on my XP Pro SP2 machine.
>
> I have a hard drive attached to my machine via a USB 2.0 drive enclosure
> (I'm not sure if this fact is even relevant). I can use the drive with no
> problems. When I right click on the drive letter and view properties,
> "General" tab, I see I do *not* have the option of compressing this drive
> for some reason.
>
> Oddly, I have a second hard drive attached to the same machine via another
> drive enclosure and this drive *does* have the option to compress.
>
> Both drives are NTFS.
>
> Can someone offer some insight as to why the one drive cannot be compressed?
>
> Thanks very much.
>
> Alan
>
>

Since they are both NTFS, my guess is that it is a cluster size
issue. Compression can be enabled only with cluster sizes of 4 KiB
or less.

Carl

Hosted by: Eyo Technologies Pty Ltd. Sponsored by: Actiontec Pty Ltd