PDA

View Full Version : "Dead keys" on all keyboard layouts for all languages stopped work



Ext User(flamey)
03-06-2007, 07:33 AM
Hi everyone!

On my computer "Dead keys" on all keyboard layouts for all languages stopped
working.

Couple of years ago i've made custom keyboard layout uing MS Keyboard Layout
Creator 1.3 based on Slovak layout - i made it so i would type all letters
with diacritics (lines, dots, and circles above some letters) through a dead
key, i picked ` key (above tab) to be the "dead" key. In contol panel
(regional settings) I left only Slovak language with my custom layout and
Russian language with standard russian layout.

All this worked great for two years, until a couple of days ago i found out
that pressing "dead key"->letter no longer produces a letter with diacritics,
but only a letter. So, before problem: dead key->a = á , now dead key->a = a
; same for all letters i setup in my layout. Also, sometimes (and i still
didn't figure out why) it now works differently - pressing dead key right
immediately produces two "base" chars - so im my custom layout its two ``, in
other layout its whatever the base character is.

The AltGrey cominations are still working fine, problem only with dead keys.
The problem is on all applications.

WinXP Home (english). Last several week I haven't install any system
software, just a couple of DB Design tools.

Here's what I tried so far:

* Safe Mode - same problem
* Installed all latest Windows updates through Windows Update except IE7 -
problem continues
* Uninstalled my custom layout (MS Keyboard Layout Creator generates both
install and uninstall). Then installed standard Slovak layout (has one dead
key different from my) - same problem.
* Removed Slovak language keyboard in control panel, added Czech (has two
dead keys) - same issue
* Uninstalled MS Keyboard Layout Creator 1.3, installed MS Keyboard Layout
Creator 1.4 (the latest i believe). Created new custom layout with 2 dead
keys - same issue.

I don't know what else to try, but i need to fix this as im back typing in
Slovak often. I'd appreciate any ideas!

--
<a href="http://www.sochi-travel.info/">My Sochi Blog</a>

Ext User(flamey)
04-06-2007, 08:46 AM
does anyone knows what DLLs are handling the keyboard? maybe i can copy them
from working system and reregester...

--
<a href="http://www.sochi-travel.info/">My Sochi Blog</a>


"flamey" wrote:

> Hi everyone!
>
> On my computer "Dead keys" on all keyboard layouts for all languages stopped
> working.
>
> Couple of years ago i've made custom keyboard layout uing MS Keyboard Layout
> Creator 1.3 based on Slovak layout - i made it so i would type all letters
> with diacritics (lines, dots, and circles above some letters) through a dead
> key, i picked ` key (above tab) to be the "dead" key. In contol panel
> (regional settings) I left only Slovak language with my custom layout and
> Russian language with standard russian layout.
>
> All this worked great for two years, until a couple of days ago i found out
> that pressing "dead key"->letter no longer produces a letter with diacritics,
> but only a letter. So, before problem: dead key->a = á , now dead key->a = a
> ; same for all letters i setup in my layout. Also, sometimes (and i still
> didn't figure out why) it now works differently - pressing dead key right
> immediately produces two "base" chars - so im my custom layout its two ``, in
> other layout its whatever the base character is.
>
> The AltGrey cominations are still working fine, problem only with dead keys.
> The problem is on all applications.
>
> WinXP Home (english). Last several week I haven't install any system
> software, just a couple of DB Design tools.
>
> Here's what I tried so far:
>
> * Safe Mode - same problem
> * Installed all latest Windows updates through Windows Update except IE7 -
> problem continues
> * Uninstalled my custom layout (MS Keyboard Layout Creator generates both
> install and uninstall). Then installed standard Slovak layout (has one dead
> key different from my) - same problem.
> * Removed Slovak language keyboard in control panel, added Czech (has two
> dead keys) - same issue
> * Uninstalled MS Keyboard Layout Creator 1.3, installed MS Keyboard Layout
> Creator 1.4 (the latest i believe). Created new custom layout with 2 dead
> keys - same issue.
>
> I don't know what else to try, but i need to fix this as im back typing in
> Slovak often. I'd appreciate any ideas!
>
> --
> <a href="http://www.sochi-travel.info/">My Sochi Blog</a>

Hosted by: Eyo Technologies Pty Ltd. Sponsored by: Actiontec Pty Ltd